Beltone Oria Opera Plus HPG (ITC) Programming


Jul 5, 2023
Reaction score
Hi, here is a problem fitting beltone opera plus HPG(itc).at starting when I click (what is connected) then it connects but when I go in fitting section and click any of MPO or frequency up and down then massage comes(Hearing aid lost the connection) even when I click end fitting then also that massage comes,I thought it may be the fault of flex strip and I changed it but still problem not solved,before connecting to software Hearing aid had sound but now its completely shutdown does anyone knows about these problem.


  • IMG-20240616-WA0063.jpg
    69.5 KB · Views: 4
  • IMG-20240616-WA0064.jpg
    47 KB · Views: 3
  • IMG-20240616-WA0065.jpg
    103.4 KB · Views: 3
  • IMG-20240617-WA0003.jpg
    100 KB · Views: 3
  • IMG-20240616-WA0065.jpg
    103.4 KB · Views: 2
  • What hearing aid fitting software are you using?
  • Your second image has the [ ] Noah box checked. Are you actually using (Noah 4 or Noah ES)?
No I am not using Noah its solus 2.7 and also I tried solus which I installed from DIY School (Free software)
Ugg; Beltone Solus 2.7 is old and sketchy; It has a patch for using Windows 8 and a couple of other patches that I don't know much about!
For all fitting software you should want the latest Legacy version for Legacy hearing aids, and for Current hearing aids you should want the latest Current version. Just follow that rule unless the latest version has a specific problem that you wish to avoid. Though, that mat not fix your problem.
Did you install it as Standalone? Otherwise I am guessing that it may be expecting running under Noa4 or Noah ES for using the Noah database instead of the Standalone database??

If you mouse/hover over the (Opera Plus HPG ITC) selection it says that you need (Cable: CS63 + Flex Strip).

I have always used (CS44 Standard Cables) and don't know much about (Cable: CS63 + Flex Strip)??

CS63 with flexstrip.jpg
Oh Pfft; maybe CS63 refers to the flexstrip;
Does your Flexstrip have a black alignment dot? I don't see the alignment dot in your image below. For the correct orientation of the alignment dot see this→ UTube video.
Thanks alot PVC I have flexstrip with 3 pins it had black dots but it was cut still it's working with all Hearing aids I think I have installed noah not standalone I will Reinstall it I hope my problem will be solved